打印

安装skype出现qt4-x11 >= 4.2,但QT都已经安好了。

安装skype出现qt4-x11 >= 4.2,但QT都已经安好了。

我在装SKYPE时,提示下面的错误,说少了包,但我已经在下载了最新的QT,并且都用了几个小时编译好了,QT的编程环境都没问题了,却还是提示下面的SKYPE安装少包包,是什么回事呢?

[root@IT60 LinuxSoftware]# rpm -ivh skype*.rpm
error: Failed dependencies:
qt4-x11 >= 4.2 is needed by skype-2.1.0.47-fc10.i586

TOP

qt4是用rpm安装的么?源码安装是不行的,rpm认不到。

TOP

晕了,我的QT4是源码编译的。好像没有RPM包吧?(可能我没看见,在官网上)

TOP

一个老外告诉我,用这个版本就搞定了,我晕。。。我原来用的是“skype-2.1.0.47-fc10.i586.rpm”,一样是从上面下载下来的。哎。

http://www.skype.com/go/getskype-linux-beta-static

TOP

飘过看没有 QT4 的白垩纪系统用户。

TOP

版主。。。太。。。。~~~:(。。。。白垩纪~~~

TOP

偶有装QT4最新版的,但。。。好像说要这个跟装软件时的依赖的概念是不一样的。麻烦。

TOP

rpm系统本身有自己的数据库保存文件信息的。而且他只记录rpm软件包安装后的信息。
源代码方式安装的程序rpm系统是不会知道你装了什么的。

另外QT4出了很久了。楼主的系统除非特老,不然应该有QT4的。现在很多系统都默认不装QT3,只装QT4了。

TOP