打印

GTK+和glib更新没用?

GTK+和glib更新没用?

用的Ubuntu9。10最近相中一款主题,到make的前一步提示说我3个东西部满足条件,一个是GNOME-desktop版本不够,第二个是glig版本不够,第三个是GTK+不够。
我就对症下药,打算一个一个升够版本,去搜GTK+进到维基百科,看了介绍以及最新版本之后,进入官网,按照提示把git给安了,然后把GTK+和glib都升到最新版,在终端里下了好久的东西,平均速度大于500k。可是完事再安那个主题还是提示少这些东西。很郁闷。

哦对了,我进心里的软件去搜这些东西,都有,但是版本都和我现有版本一样,官方列出的最新版本都没有。版本号差那么零点几。
我想问的是,GTK+      glib版本能更新吗,

TOP

你没装开发部分吧?
最主要的是 pkgconfig 这个程序,超小的程序,但他是很多程序搜索某个程序的版本的首要选择。他的功能很简单,通过读取对应软件提供的 *.pkg 文件,输出这个程序的对应配置信息。
没有安装这个程序,或者没装 pkgconfig 的数据文件,那么软件永远也不能识别某个系统库的版本。

而且,ubuntu 人家本来就借助 deb 包管理器,有一套完整的系统关系库,你这么从源代码安装系统库,那么整个系统的软件统一管理完全破坏了。

TOP

那么,也就是说我安一个泥说的那个包就行了吗???

TOP

这要看这个程序的源代码到底需要哪些开发库程序了。

TOP