打印

Win7+VMware7.0下CentOS上网如何设置(内含尝试介绍)

Win7+VMware7.0下CentOS上网如何设置(内含尝试介绍)

首先说明一下Win7是家庭版的,不只会不会有严重的影响。曾在XP+VMware5条件下按此方法设置成功上网。
PPPoE上网环境
下面介绍下已经做的尝试:
        Ⅰ:
                1.VMware网卡设置为Host-Only
                2.在VMware-Edit-Virtual Network Editor中,将VMnet1取消DHCP,Subnet IP设置为192.168.137.0 子网掩码为255.255.255.0(以后的子网掩码均如此设置) (ps:XP下没有设置过,网上搜索的- -#)
                3.在Win7下,VMnet1设置 IP:192.168.137.1
                4.本地连接设置为自动获取IP地址。
                5.PPPoE拨号设置对VMnet1共享,并将VMnet1IP设置为192.168.137.1
        Ⅱ:
                1.cd /etc/sysconfig/network-scripts  vi ifcfg-eth0
                2.设置如下:
                        DEVICE=eth0
                        BOOTPROTO=static
                        ONBOOT=yes
                        IPADDR=192.168.137.40
                        NETMASK=255.255.255.0
                        BROADCAST=192.168.137.255
                        GATEWAY=192.168.137.1
                3.service network restart
                4.ping -c 3 192.168.137.1
       
        最终结果就是ping不通,目前在网上关于Win7+VMware+Linux的文章很少,看了很多设置方法,总结起来就是上面的了。
        还有一个发现不知道有用没,原来ping都是什么什么unreachable   现在ping发送3个包的状态全都不显示了
        希望哪位大虾指点一下~~TKS~

TOP

反馈1:
        将本地连接IP设置手动,与VMnet1处于同一网段,将网络类型设置为工作网络,可成功ping通网关。
        出现问题:PPPoE连接后,就ping不通网关。   
        具体说明宿主主机网络环境:网线接宿舍路由器,Win7识别为“未识别的网络”,公共网络环境,访问类型:无法连接到Internet。本地连接、VMnet1、VMnet8均为“无网络访问权限”或“无Internet访问权限”。
        总结:问题应该出现在Win7网络设置环节上,可对Win7和当下的网络环境(偷偷自己接的)真的了解甚少。。

TOP

瞎折腾什么啊……
虚拟机里面的系统用 DHCP ,虚拟机软件用 NAT ,拨号用 Windows 播。

TOP

回复 3# jiangtao9999 的帖子

问题应该出在Win7网络设置上了
正在考虑换系统。。

TOP

很明显不是。主要原因是你非要绕过 vmware 的网络功能而去使用 windows 7 的网络功能。

Windows Vista 开始,网络部分的功能加强了安全设置,我觉得你应该是被某些新增加的安全功能干扰了网络共享。新的 Windows 网络管理,比 XP 多了无数的新设置。

TOP

不明白为什么你会说“’出在Win7网络设置上‘很明显不是”。。   和你后面解释的有什么区别 呵呵~~
既然用的VMware,怎么可能绕过他的网络功能呢?
我找了一篇通过NAT方式的文章(http://blog.csdn.net/wenlifu71022/archive/2009/08/17/4454210.aspx)   不知道是否妥当?

我的猜想是HOME就跟以前的XP HOME一样,网络功能貌似不完善吧?

TOP

我非常赞同“被某些新增加的安全功能干扰了网络共享”
所以我目前需要的帮助是 宿主主机是Win7的条件下使用VMware+Linux上网,Win7的网络设置应该是怎样的,如果有好的文章,欢迎介绍给我,非常感谢。

TOP

刚刚测试过了,NAT方式也是出现相同情况。
换系统,啥也不说了。。。

TOP

虚拟机里面的系统根本不需要设置网络,直接 DHCP 就能使用虚拟机软件提供的 NAT 接入方式。
所有说要修改虚拟机里面系统的设置的,全是错的。

你如果设置了,要全都恢复成刚安装的状态。包括实体机器上的虚拟网卡,和虚拟机软件里面的各种设置。
虚拟机工作在 NAT 和桥接还有 host-only 的网络设置,我要没记错是不同的。你如果修改了设置,那么就有可能音响虚拟机本身设计需要的参数。

TOP

涛涛是明白人,呵呵

TOP