打印

笔记本电脑Xorg问题

笔记本电脑Xorg问题

我的笔记本电脑的型号是thinkpad SL410K,在命令行下输入Xorg &进入X视窗系统,一切都很正常,虽然屏幕全都是黑黑的一片,但我知道那是X运行之后产生的一个根视窗。
    之后按ctrl+alt+f1返回到虚拟控制台,xterm -display :0连接过去,按alt+f7切换回视窗,用笔记本的触摸板鼠标操作一下,可以在屏幕上左右上下移动,但是一松开手就不行了,鼠标并不停留在原位置,而是自动往屏幕左边移动,你把它移到中间来,它有自己跑回屏幕左边。请问只是什么回事?

TOP

………………

[ 本帖最后由 panpanpdj 于 2010-12-17 21:05 编辑 ]

TOP

触摸板驱动?
楼上没那技术就不要说别人了。你可以去水园看看我的计算机配置。

TOP

引用:
原帖由 jiangtao9999 于 2010-12-17 14:15 发表
触摸板驱动?
楼上没那技术就不要说别人了。你可以去水园看看我的计算机配置。
不是,触摸板可以控制鼠标的光标在屏幕上移动了,但是你松手之后光标就总是向屏幕的左下角或者是左上角靠,移到中间来它又靠回去。不过我接一个USB接口的鼠标上去,就很正常,不会左晃右晃的。
复制内容到剪贴板
代码:
Section "ServerLayout"
        Identifier     "X.org Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
        ModulePath   "/usr/lib/xorg/modules"
        FontPath     "/usr/share/fonts/misc/"
        FontPath     "/usr/share/fonts/TTF/"
        FontPath     "/usr/share/fonts/OTF/"
        FontPath     "/usr/share/fonts/Type1/"
        FontPath     "/usr/share/fonts/100dpi/"
        FontPath     "/usr/share/fonts/75dpi/"
EndSection

Section "Module"
        Load  "dri"
        Load  "record"
        Load  "dbe"
        Load  "dri2"
        Load  "glx"
        Load  "extmod"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option            "Protocol" "auto"
        Option            "Device" "/dev/input/mice"
        Option            "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor Model"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "AccelMethod"                # [<str>]
        #Option     "DRI"                        # [<bool>]
        #Option     "ColorKey"                   # <i>
        #Option     "VideoKey"                   # <i>
        #Option     "FallbackDebug"              # [<bool>]
        #Option     "Tiling"                     # [<bool>]
        #Option     "Shadow"                     # [<bool>]
        #Option     "SwapbuffersWait"            # [<bool>]
        #Option     "XvMC"                       # [<bool>]
        #Option     "XvPreferOverlay"            # [<bool>]
        #Option     "DebugFlushBatches"          # [<bool>]
        #Option     "DebugFlushCaches"           # [<bool>]
        #Option     "DebugWait"                  # [<bool>]
        Identifier  "Card0"
        Driver      "intel"
        BusID       "PCI:0:2:0"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        SubSection "Display"
                Viewport   0 0
                Depth     1
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     4
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     8
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     15
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     16
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection
[ 本帖最后由 roofers 于 2010-12-19 10:57 编辑 ]

TOP

evdev驱动装了么?现在xorg不用配置文件会自动识别,所以遇到问题先用自动识别驱动,现在能用的驱动很多,不停的换驱动找支持的能用的驱动。触摸板的驱动和鼠标我记得不是一个。

TOP