打印

KDE 4.2.1 for MagicLinux 已经可用 ^_^(421) <--- :P :> :D

KDE 4.2.1 for MagicLinux 已经可用 ^_^(421) <--- :P :> :D

如题:

还不知道 kde4 的话,建议看看 kde 中国官方的介绍吧~
http://www.kdecn.org/announcements/4.1/
强烈建议
http://www.kdecn.org/announcements/4.0/guide.php

已经经过本人测试运行。
功能正常,包括 kwin 特效、声音系统、plasma 的各个部件、solid 等等.....


========这里开始是 KDE 4.1.x 的(不再维护~)======华丽的分割线==========

请见本帖二楼~


========这里开始是 KDE 4.2.x 的======华丽的分割线==========

安装方法:
添加 apt 源。
root 权限:
/etc/apt/sources.list.d/magic.list

添加一行(KDE 4.2 rc1 之后不需要):
复制内容到剪贴板
代码:
rpm http://wiki.magiclinux.org/ftp/nihui kde4related
然后在 root 状态下执行(su):
复制内容到剪贴板
代码:
wget http://wiki.magiclinux.org/ftp/nihui/kde4/6D1FD84A.asc(KDE 4.2 rc1 之后不需要)
rpm --import 6D1FD84A.asc(KDE 4.2 rc1 之后不需要)
apt-get update
apt-get dist-upgrade
apt-get install kde4-session qt4-cjk
同样,也可以使用 smart 进行安装。

qt4 版本:
Qt = 4.4.3 正式版

安装完成之后,无需修改任何配置文件等等,只需注销一下便能进入!
注销,回到登录的地方,输入用户名和密码,然后在下面的菜单里面选 “KDE 4” 就进去了啊~~

KDE 4.1.x 可以平滑升级到 4.2.x,且附属程序可以通用~
wiki 上的 rpm 包引入了 opengpg 密钥签名机制。
自 4.0.3 版本起,对 startkde 脚本进行了修改配置:今后在 KDE4 环境中使用 kde3 程序将无需重新配置而可直接使用 ~/.kde/ 目录的配置。KDE4(~/.kde4/) 和 KDE3 程序的配置则不会混淆。
同时,除了基本的桌面软件包之外,附加的主程序包使用细化分包原则。kdegraphics4 这种名称依然能够通用且可以单独安装其中的某些程序。

修正 juk 乱码问题、修正无法播放中文文件名媒体问题

Qt4 版本升级到 4.4.3 正式版



简体中文语言包安装:
复制内容到剪贴板
代码:
apt-get install kde4-l10n-zh_CN
kdegraphics(包含 okular/gwenview 等):
apt-get install kdegraphics4

kdeedu(包含 kalzium/marble/step 等):
apt-get install kdeedu4

kdeaccessibility(包含 kttsd/kmag 主题 等):
apt-get install kdeaccessibility4

kdegames(包含 ksudoku 等):
apt-get install kdegames4

kdenetwork(包含 kopete/krdc 等):
apt-get install kdenetwork4

kdesdk(包含 kompare/poxml 等):
apt-get install kdesdk4

kdepim(包含 kmail/kontact 等):
apt-get install kdepim4

kdetoys(包含 amor 等):
apt-get install kdetoys4

kdeutils(包含 sweeper/kalarm/ark 等):
apt-get install kdeutils4

kdeartwork(包含 额外的桌面背景/图标/ plasma 主题 等):
apt-get install kdeartwork4

kdeadmin(包含 kpackager 等):
apt-get install kdeadmin4

kdeplasma-addons(包含 comic 等众多额外的 plasma 部件):
apt-get install kdeplasma-addons

kdemultimedia(包含 kmix/juk 等):
apt-get install kdemultimedia4

kdewebdev(包含 klinkstatus 等):
apt-get install kdewebdev4

kdebindings(包含 pyKDE4/Qtruby/Qtsmoke 等):
apt-get install kdebindings4



其它 kde4 组件:
kde4-kipi-plugins
kde4-digikam
kde4-kmplayer
kdevplatform
kdevelop4
amarok2

详细信息:
本次打包的 kde4 是稳定版──4.2.0。
akonadi = 1.1.1
strigi = 0.6.3
cmake = 2.6.2
soprano = 2.1.67
qimageblitz = 0.0.5
phonon = 4.3.0

相关依赖软件包编译打包平台:MagicLinux 2.1 final
主 kde4 软件包编译打包平台:MagicLinux 2.1 final

提供的 apt 源中包含了所有的 devel 包以及直接依赖的软件包和依赖软件包的编译依赖等等......
所以大家如果喜欢自己编译的话,也是完全可以的~

将会更新的系统包:cmake, taglib, strigi

2009/1/26
补充详细注释
以下为各个部件的真实版本:
复制内容到剪贴板
代码:
kdelibs                        4.2.0(svn 915525) 
kdepimlibs                   4.2.0(svn 914528)
kdebase-runtime         4.2.0(svn 914912)
kdebase                      4.2.0(svn 914528)
kdebase-workspace    4.2.0(svn 914528)
kdeaccessibilty            4.2.0(svn 914528)
kdeartwork                  4.2.0(svn 914528)
kdeadmin                    4.2.0(svn 914528)
kdebindings                 4.2.0(svn 914528)
kdeedu                        4.2.0(svn 914528)
kdegames                   4.2.0(svn 914528)
kdegraphics                4.2.0(svn 914528)
kdemultimedia            4.2.0(svn 914528)
kdenetwork                4.2.0(svn 914528)
kdepim                       4.2.0(svn 914528)
kdeplasma-addons     4.2.0(svn 914528)
kdesdk                       4.2.0(svn 914528)
kdetoys                      4.2.0(svn 914528)
kdeutils                      4.2.0(svn 914528)
kdewebdev                 4.2.0(svn 914528)  
kopete(kdenetwork) 的 qq 用的是 qq2006 新春版协议,已经失效,所以无法登录。
kalzium(kdeedu) 中的化学方程式配平功能需要 ocaml 和 facile 支持,3D 分子查看器需要 openbabel 支持。
kdepim 组件由于质量不过关,没有发布,因此我也不提供 svn 版本了。
关于 K 菜单使用不习惯的问题,可以见此帖:http://www.linuxfans.org/bbs/thread-182207-1-1.html
在 KDE4 中可以正常使用 KDE3 中的程序,而 KDE3 中的 K 菜单则不会出现 KDE4 的程序项目。
最后,请经常使用 apt-get update && apt-get dist-upgrade 进行更新检查~



截图稍后奉上~

TOP

========这里开始是 KDE 4.1.x 的~======华丽的分割线==========


安装方法:
添加 apt 源。
root 权限打开:
/etc/apt/sources.list.d/magic.list

添加一行:
复制内容到剪贴板
代码:
rpm http://wiki.magiclinux.org/ftp/nihui kde4 kde4related kde41x
请一定要删除以前 rc2/beta3/400/401/40x 的源,否则可能造成冲突
4.1.0/4.1.3 的源可直接从官方仓库升级得到。-------- apt.magiclinux.org 之 2.1 的 unstable/extras 源,
4.1.1/4.1.2 的源可直接从官方仓库升级得到。-------- apt.magiclinux.org 之 2.1 的 unstable/os 源,
仍然添加第三方源是为了满足依赖关系


然后在 root 状态下执行(su):
复制内容到剪贴板
代码:
wget http://wiki.magiclinux.org/ftp/nihui/kde4/6D1FD84A.asc
rpm --import 6D1FD84A.asc
apt-get update
apt-get dist-upgrade
apt-get install kde4-session qt4-cjk
同样,也可以使用 smart 进行安装。

qt4 版本:
Qt = 4.4.3 正式版

安装完成之后,无需修改任何配置文件等等,只需注销一下便能进入!
注销,回到登录的地方,输入用户名和密码,然后在下面的菜单里面选 “KDE 4” 就进去了啊~~

KDE 4.0.x 可以平滑升级到 4.1.x,但是附属程序不能可以通用~(偶尔几个外围软件可以通用)
wiki 上的 rpm 包引入了 opengpg 密钥签名机制。
自 4.0.3 版本起,对 startkde 脚本进行了修改配置:今后在 KDE4 环境中使用 kde3 程序将无需重新配置而可直接使用 ~/.kde/ 目录的配置。KDE4(~/.kde4/) 和 KDE3 程序的配置则不会混淆。
同时,除了基本的桌面软件包之外,附加的主程序包使用细化分包原则。kdegraphics4 这种名称依然能够通用且可以单独安装其中的某些程序。

较 40x 修正的问题:
nepomuk 服务启动错误造成 kded4 无法启动的问题。
juk/dragonplayer 等 kde4 播放器无法播放中文文件名歌曲的问题。
juk 标签乱码问题。
konqueror/dolphin/....(几乎是所有书签部件) 书签乱码问题


简体中文语言包安装:
复制内容到剪贴板
代码:
apt-get install kde4-l10n-zh_CN
kdegraphics(包含 okular/gwenview 等):
apt-get install kdegraphics4

kdeedu(包含 kalzium/marble/step 等):
apt-get install kdeedu4

kdegames(包含 ksudoku/kdiamond 等):
apt-get install kdegames4

kdetoys(包含 amor 等):
apt-get install kdetoys4

kdenetwork(包含 kopete/krdc 等):
apt-get install kdenetwork4

kdepim(包含 kmail/kontact 等):
apt-get install kdepim4

kdesdk(包含 kompare/poxml/lokalize 等):
apt-get install kdesdk4

kdeutils(包含 sweeper/kalarm/ark 等):
apt-get install kdeutils4

kdebindings(包含 pykde4/qt4ruby 等):
apt-get install kdebindings4

kdeadmin(包含 kpackager 等):
apt-get install kdeadmin4

kdeaccessibility(包含 kmag 等):
apt-get install kdeaccessibility4

kdeplasma-addons(包含 comic 等众多额外的 plasma 部件):
apt-get install kdeplasma-addons

kdemultimedia(包含 kmix/juk 等):
apt-get install kdemultimedia4

kdewebdev(包含 klinkstatus 等):
apt-get install kdewebdev4

kdeartwork(包含 额外的图标集 等):
apt-get install kdeartwork4


其它 kde4 组件:
kipi-plugins
digikam
amarok2
kmess2
kmldonkey2

详细信息:
本次打包的 kde4 是稳定版本──4.1.x。
strigi = 0.5.11
cmake = 2.6.2
soprano = 2.1.1
qimageblitz = 0.0.4
akonadi = 1.0.0
phonon = 4.2.0

相关依赖软件包编译打包平台:MagicLinux 2.1 >= rc1
主 kde4 软件包编译打包平台:MagicLinux 2.1 >= rc1

提供的 apt 源中包含了所有的 devel 包以及直接依赖的软件包和依赖软件包的编译依赖等等......
所以大家如果喜欢自己编译的话,也是完全可以的~

将会更新的系统包:cmake、strigi、taglib

2008/09/30
补充详细注释
以下为各个部件的真实版本:
复制内容到剪贴板
代码:
kdelibs                        4.1.3(svn 877859) 
kdepimlibs                   4.1.3(svn 877859)
kdebase-runtime         4.1.3(svn 877859)
kdebase                      4.1.3(svn 877859)
kdebase-workspace    4.1.3(svn 877859)
kdebindings                4.1.3(svn 877859)
kdeadmin                    4.1.3(svn 877859)
kdeaccessibility           4.1.3(svn 877859)
kdeedu                        4.1.3(svn 877859)
kdegames                   4.1.3(svn 877859)
kdepim                       4.1.3(svn 877859)
kdeplasma-addons     4.1.3(svn 877859)
kdegraphics                4.1.3(svn 879927)
kdemultimedia            4.1.3(svn 877859)
kdenetwork                 4.1.3(svn 877859)
kdesdk                        4.1.3(svn 877859)
kdetoys                      4.1.3(svn 877859)
kdeutils                      4.1.3(svn 877859)
kdewebdev                 4.1.3(svn 877859)
kopete(kdenetwork) 的 qq 用的是 qq2006 新春版协议,已经失效,所以无法登录。
kalzium(kdeedu) 中的化学方程式配平功能需要 ocaml 和 facile 支持,3D 分子查看器需要 openbabel 支持。
关于 K 菜单使用不习惯的问题,可以见此帖:http://www.linuxfans.org/bbs/thread-182207-1-1.html
在 KDE4 中可以正常使用 KDE3 中的程序,而 KDE3 中的 K 菜单则不会出现 KDE4 的程序项目。
最后,请经常使用 apt-get update && apt-get dist-upgrade 进行更新检查~




[ 本帖最后由 nihui 于 2008-11-8 08:46 编辑 ]

TOP

很快,有速度。
----------------------欢迎登录以下空间-------------------

TOP

谢谢nihui兄的辛苦

辛苦啦,马上去试试!!

TOP

呵呵,不错阿

TOP

很好看,真的希望能够尽快用上。

TOP

好啊,真是太好了!!!

TOP

装上了,第一感觉不错,但用了下还是有些问题
声音没有了xine好像不正确
没能开启桌面效果,可能驱动有关了 inte 855g的显卡

慢慢来了~
努力C 为儿时的游戏梦~ 喜欢Linux里边人们无私奉献的那种精神~

TOP

引用:
原帖由 SCerZZ 于 2008-1-14 17:10 发表
装上了,第一感觉不错,但用了下还是有些问题
声音没有了xine好像不正确
没能开启桌面效果,可能驱动有关了 inte 855g的显卡

慢慢来了~
xine 升级到 1.1.9 了,kwin 桌面特效如果打不开,可以尝试使用 Xrendr 模式,而不是 OpenGL..........

TOP

严重支持啊。
http://haulm.clanmark.com
自古多情空余恨,几人独潇洒。
问君相伴何所思,唯叹红叶飞。
凭栏窗外一皓月,冷风抚面,寒星如冰。
回想前事独伤感,难分难离,倒是山峦草芥,依旧青。

TOP

good  job

TOP

相当漂亮。楼主强人啊。

TOP

支持楼主!

TOP

怎么回事呢?

apt-get install kde4-l10-zh_CN
Reading Package Lists... Done
Building Dependency Tree... Done
E: Couldn't find package kde4-l10-zh_CN

TOP

引用:
原帖由 qqq_huo 于 2008-1-20 13:11 发表
apt-get install kde4-l10-zh_CN
Reading Package Lists... Done
Building Dependency Tree... Done
E: Couldn't find package kde4-l10-zh_CN
楼主的笔误,应该是
apt-get install kde4-l10n-zh_CN

[ 本帖最后由 xx_zz 于 2008-1-20 14:54 编辑 ]

TOP