打印

gentoo 升级 world 提示 slot conflict 问题

gentoo 升级 world 提示 slot conflict 问题

各位兄台,今天升级 world 提示:
复制内容到剪贴板
代码:
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/libgcrypt:0

  (dev-libs/libgcrypt-1.5.3::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/libgcrypt-1.5.0-r2::gentoo, installed) pulled in by
    >=dev-libs/libgcrypt-1.1.42:0/0= required by (dev-libs/libxslt-1.1.28-r1::gentoo, installed)

dev-libs/icu:0

  (dev-libs/icu-51.1::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/icu:0/51.1 required by (app-office/libreoffice-bin-4.0.4.2::gentoo, ebuild scheduled for merge)

  (dev-libs/icu-49.1.2::gentoo, installed) pulled in by
    dev-libs/icu:0/0= required by (sys-apps/gptfdisk-0.8.6::gentoo, installed)

sys-libs/zlib:0

  (sys-libs/zlib-1.2.7::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (sys-libs/zlib-1.2.7::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-libs/zlib-1.2.5.1-r2:0[minizip] required by (dev-db/virtuoso-server-6.1.6::gentoo, ebuild scheduled for merge)

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.
这个解释是什么意思,不太懂:

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

最新的 dev-libs/libgcrypt-1.5.3 满足 >=dev-libs/libgcrypt-1.1.42 依赖
最新的 sys-libs/zlib-1.2.7 也满足 >=sys-libs/zlib-1.2.5.1-r2 依赖

为什么不让装。。。


---

TOP

你得结合前面的提示看
你贴的这些只是一部分,表明这些软件包都被谁依赖了。

TOP

---

mask 掉这几个新的软件包,重新更新的所有输出贴到这里了:http://ix.io/6XK

=dev-libs/libgcrypt-1.5.2-r1
=dev-libs/icu-51.1
=app-office/libreoffice-bin-4.0.4.2
=dev-db/virtuoso-server-6.1.6

这段显示,应该是下面这些软件包导致的依赖问题吧:
复制内容到剪贴板
代码:
The following mask changes are necessary to proceed:
(see "package.unmask" in the portage(5) man page for more details)
# required by dev-libs/soprano-2.9.2[virtuoso]
# required by kde-base/nepomuk-widgets-4.10.5
# required by kde-base/kdelibs-4.10.5-r1[semantic-desktop]
# required by kde-base/phonon-kde-4.10.5
# required by kde-base/kdebase-startkde-4.10.5
# required by @selected
# required by @world (argument)
# /etc/portage/package.mask:
=dev-db/virtuoso-server-6.1.6
现在的系统没有安装:dev-db/virtuoso-server 和 dev-libs/soprano-2.9.2[virtuoso]

如果 mask 掉 =sys-libs/zlib-1.2.7 会出现这个提示,应该是 dev-db/virtuoso-server 依赖旧版本的 sys-libs/zlib-1.2.5.1-r2 但是现在系统安装的已经是新版的 sys-libs/zlib-1.2.7
复制内容到剪贴板
代码:
sys-libs/zlib:0

  (sys-libs/zlib-1.2.5.1-r2::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-libs/zlib-1.2.5.1-r2:0[minizip] required by (dev-db/virtuoso-server-6.1.6::gentoo, ebuild scheduled for merge)

  (sys-libs/zlib-1.2.7::gentoo, installed) pulled in by
    >=sys-libs/zlib-1.2.6 required by (sys-apps/kmod-13-r1::gentoo, ebuild scheduled for merge)
---

TOP

---
复制内容到剪贴板
代码:
 · sudo emerge -avj sys-libs/zlib      

[ebuild   R    ] sys-libs/zlib-1.2.7  USE="-minizip -static-libs" 548 kB
现在的 sys-libs/zlib 没有启用 minizip USE 我添加之后就 OK 了

---

TOP


叫你不看全了

TOP

可能我把焦点全放到错误提示了,添加了
复制内容到剪贴板
代码:
# required by dev-db/virtuoso-server-6.1.6
# required by dev-libs/soprano-2.9.2[virtuoso]
# required by kde-base/nepomuk-widgets-4.10.5
# required by kde-base/kdelibs-4.10.5-r1[semantic-desktop]
# required by kde-base/phonon-kde-4.10.5
# required by kde-base/kdebase-startkde-4.10.5
# required by @selected
# required by @world (argument)
=sys-libs/zlib-1.2.7 minizip
把其他的两个 mask 去掉,都 OK 了,还是有些奇怪,为什么之前会有冲突
之后就没有冲突了?
复制内容到剪贴板
代码:
[ebuild  rR    ] dev-libs/libxslt-1.1.28-r1  USE="crypt -debug -python -static-libs" PYTHON_TARGETS="python2_7 -python2_5 -python2_6" 0 kB
[ebuild  r  U  ] dev-libs/icu-51.1:0/51.1 [49.1.2:0/0] USE="-debug -doc -examples -static-libs" 21,304 kB
[ebuild  r  U  ] dev-libs/libgcrypt-1.5.3:0/11 [1.5.0-r2:0/0] USE="-static-libs" 1,474 kB
[ebuild  rR    ] sys-apps/gptfdisk-0.8.6  USE="icu ncurses -static" 0 kB

TOP

估计是因为有软件依赖  zlib 的 minizip 的 USE 。有些软件不需要,但升级又需要某些软件一起升级,导致依赖 minizip 的软件和不需要 minizip 的软件和 zlib 互相之间和依赖依赖minizip的软件的软件产生了一个依赖冲突。
这东西必须看全了,那些依赖的提示,只是说当前有问题的软件包被谁依赖。只是方便你进行取舍的东西。对于实际问题的所在,不在这些提示上。

TOP