中国Linux公社论坛's Archiver

gxcooo 发表于 2005-11-20 21:50

BitStorm 0.2p Lite released

[color=red]
0.2p彻底修正了无法完整下载>4GB文件的问题
[url]http://sourceforge.net/projects/bbom/[/url]
[/color]

0.2n修正了下载大于4GB文件时最后一块数据有可能无法正常下载的问题
[url]http://sourceforge.net/projects/bbom/[/url]


0.2k没有代码上的改动,只是在源代码文件中加入GPL2声明,为进入Ubuntu和Debian官方软件仓库做的正规化改进
另外没有0.2j版,因为j和i不易区分
[url]http://sourceforge.net/projects/bbom/[/url]

0.2i修正了0.2h不能发起连接的bug
[url]http://sourceforge.net/projects/bbom/[/url]

0.2h修正了无法正确下载大于4GB文件的bug,界面有改进
优化了连接策略
强烈建议更新
[url]http://sourceforge.net/projects/bbom/[/url]

0.2g修正了peerID不唯一的bug,此bug可能会导致和旧的BT客户端无法建立P2P连接
[url]http://sourceforge.net/projects/bbom/[/url]

0.2f修正了无法在64位OS上无法下载的bug
[url]http://sourceforge.net/projects/bbom/[/url]


0.2e修正了一个bug,此bug会导致下载速度下降,长时间可能降为0kbps
[url]http://sourceforge.net/projects/bbom/[/url]

0.2d主要是修正了上传策略,提高了下载速度

[url]http://sourceforge.net/projects/bbom/[/url]

0.2c修正了如下bug
1)无法打开无效utf-8编码文件名的torrent文件,已经修正
2)和某些TP-Link型号路由器进行UPnpNat操作时会导致cpu占用100%,已经修正
3)不能下载超过2G的文件,已经修正


0.2b加入上传/下载速度限制功能
0.2a增加Torrent字符集编码选择,使用非UTF-8编码的Torrent文件时不会出现乱码啦
0.2版新增多文件选择下载功能,可单独下载某些文件,支持compact模式的Tracker

BitStorm 0.2 Lite主要特性如下
1)基于C++和GTK2,占用系统资源少
2)可调整大小的磁盘缓存,极大的减轻磁盘负担
3)支持多Tracker,支持UDP Tracker,支持compact模式HTTP Tracker
4)UPnp NAT功能,自动进行端口映射(默认监听端口为7681~7689)
5)支持多文件选择性下载,可单独下载某些文件
6)支持UTF-8编码的Torrent文件,文件名不会出现乱码
7)可设置上传/下载速度

[[i] 本帖最后由 gxcooo 于 2007-12-1 15:37 编辑 [/i]]

dukeduan 发表于 2005-11-21 10:20

这个版本dht协议搞定了吗? :-D

gxcooo 发表于 2005-11-21 11:34

to dukeduan:
没有 , 太忙了:cry:

dukeduan 发表于 2005-11-21 12:15

//comfort
正事为主,正事为主。 :mrgreen:

gbyst 发表于 2005-11-21 12:21

请问这个客户端支持内网互连吗?我在内网,其他Linux下的bt软件都不能用

superman 发表于 2005-12-6 17:40

比azureus好吗?

ogog 发表于 2005-12-6 23:43

没说的,顶就一个。

dukeduan 发表于 2005-12-7 12:48

越做越好了。支持。

more2005 发表于 2005-12-7 18:36

建议斑竹将5q算法板块编译成.o文件放在压缩包内,不知可不可以

fyfw 发表于 2005-12-7 21:47

在freebsd下能用吗?

gxcooo 发表于 2005-12-7 21:54

to fyfw:
http://bbs.chinaunix.net/viewthread.php?tid=657160&extra=&page=2

pinkme005 发表于 2005-12-8 20:31

GOOD....越来越好用了。。。。

shuaiant 发表于 2005-12-11 12:20

期待dht协议开发出来。现在内网速度还是很慢。

peaceman 发表于 2005-12-12 20:52

checking for GTK... Requested 'gtk+-2.0 >= 2.6.0' but version of GTK+ is 2.4.0
configure: error: Package requirements (gtk+-2.0 >= 2.6.0) were not met.
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively you may set the GTK_CFLAGS and GTK_LIBS environment variables
to avoid the need to call pkg-config.  See the pkg-config man page for
more details.

我得是红旗4.1

飞上墙头看啊 发表于 2005-12-16 16:53

requirements (gtk+-2.0 >= 2.6.0)

sunperz 发表于 2005-12-21 13:09

这个是什么错误?
configure: error: the curl-config script installed by libcurl could not be found                    
.  libcurl is required.

gxcooo 发表于 2005-12-21 14:16

to sunperz:
请安装libcurl-dev

gxcooo 发表于 2005-12-21 14:18

to sunperz:
请安装libcurl-dev

wanjinyou 发表于 2005-12-25 13:42

我在FC4下也搞不定,同样的错误

[quote:734dc3fba1="peaceman"]checking for GTK... Requested 'gtk+-2.0 >= 2.6.0' but version of GTK+ is 2.4.0
configure: error: Package requirements (gtk+-2.0 >= 2.6.0) were not met.
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively you may set the GTK_CFLAGS and GTK_LIBS environment variables
to avoid the need to call pkg-config.  See the pkg-config man page for
more details.

我得是红旗4.1[/quote]

看到楼上说需要安装libgtk2.0的包,在网上找了半天也没有弄到,哪位大哥帮帮忙啊。

dlz_cn 发表于 2006-1-19 00:18

比较完整的一个 deb 包
设置了 mime , desktop file。
不过 Duild-Depends 可能还不够完整,慢慢来吧。

http://linuxfire.dhis.org/~optical/Debian/bitstormlite/

gxcooo 发表于 2006-1-19 10:01

谢谢dlz_cn 8)

飞上墙头看啊 发表于 2006-1-19 10:47

$ sudo dpkg -i bitstormlite_2.0b-0.0_i386.deb
dpkg-deb: “bitstormlite_2.0b-0.0_i386.deb”并非 debian 格式的包文件
dpkg:处理 bitstormlite_2.0b-0.0_i386.deb (--install)时出错:
子进程·dpkg-deb --control·返回了错误号·2
在处理时有错误发生:
bitstormlite_2.0b-0.0_i386.deb

:shock:  :shock:

dlz_cn 发表于 2006-1-19 11:02

我刚才在更新

重新下载吧。

飞上墙头看啊 发表于 2006-1-21 06:41

[code:1]$ sudo dpkg -i bitstormlite_0.2b-0.0_i386.deb
(正在读取数据库 ... 系统当前总共安装有 60864 个文件和目录。)
正预备替换 bitstormlite 0.2b-0.0 (使用 bitstormlite_0.2b-0.0_i386.deb) ...
正在解压缩将用于更替的包文件 bitstormlite ...
dpkg:依赖关系问题使得 bitstormlite 的配置工作不能继续:
bitstormlite 依赖于 libcairo2 (>= 1.0.2-2);然而:
  系统里的 libcairo2 的版本是 1.0.2-0ubuntu1.
bitstormlite 依赖于 libcurl3 (>= 7.15.0-1);然而:
  系统里的 libcurl3 的版本是 7.14.0-2ubuntu1.
bitstormlite 依赖于 libgcc1 (>= 1:4.0.2);然而:
  系统里的 libgcc1 的版本是 1:4.0.1-4ubuntu9.
bitstormlite 依赖于 libglib2.0-0 (>= 2.8.5);然而:
  系统里的 libglib2.0-0 的版本是 2.8.3-0ubuntu1.
bitstormlite 依赖于 libidn11 (>= 0.5.18);然而:
  系统里的 libidn11 的版本是 0.5.13-1.0.
bitstormlite 依赖于 libkrb53 (>= 1.4.2);然而:
  系统里的 libkrb53 的版本是 1.3.6-4.
bitstormlite 依赖于 libpango1.0-0 (>= 1.10.2);然而:
  系统里的 libpango1.0-0 的版本是 1.10.1-0ubuntu1.
bitstormlite 依赖于 libssl0.9.8 (>= 0.9.8a-1);然而:
  软件包 libssl0.9.8还没有被安装。
bitstormlite 依赖于 libstdc++6 (>= 4.0.2-4);然而:
  系统里的 libstdc++6 的版本是 4.0.1-4ubuntu9.
bitstormlite 依赖于 libxrender1 (>= 1:0.9.0.2);然而:
  系统里的 libxrender1 的版本是 1:0.9.0-1.
dpkg:处理 bitstormlite (--install)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
bitstormlite[/code:1]


现在库里面好像都没有这么高的版本 :-(
这要是一个一个包的找还不累死了!
你的testing包是从哪里下载的??

dlz_cn 发表于 2006-1-21 14:42

你搞错版本的。
我 deb 里面写 unstable 当然就是给 debian sid 用的。

ubuntu 就得你自己重新编译了。

这些和 testing (debian etch) 没有什么关系。

飞上墙头看啊 发表于 2006-1-21 15:55

[quote:f1fd97f148="dlz_cn"]你搞错版本的。
我 deb 里面写 unstable 当然就是给 debian sid 用的。

ubuntu 就得你自己重新编译了。

这些和 testing (debian etch) 没有什么关系。[/quote]

:cry:  :cry:  :cry:  :cry:  :cry:  :cry:  :cry:

飞上墙头看啊 发表于 2006-1-21 22:09

还好,终于编译成功了!

奇怪前几次为什么编译总是通不过??莫非是RPWT?? :-(

飞上墙头看啊 发表于 2006-1-21 22:11

PS TO:gxcooo

俺很喜欢你的这个软件! :o

ogog 发表于 2006-1-22 17:21

救命!sourceforge上不了了!

飞上墙头看啊 发表于 2006-1-28 20:10

to gxcooo

春节快乐! :mrgreen:

页: [1] 2 3

Powered by Discuz! Archiver 6.1.0F  © 2001-2007 Comsenz Inc.