中国Linux公社论坛's Archiver

wsl815 发表于 2006-9-1 13:52

[问题]诚问,firefox1.5装完后scim不能启动

环境Ubuntu 5.10 breezy
英文locale
scim1.4.2

此前的几乎所有程序中scim均可正常使用,包括firefox1.0 。
安装firefox1.5后,按照论坛上讲的在 /usr/bin/firefox 脚本中添加如下代码
export GTK_IM_MODULE=xim

firefox可正常启动,可是scim却不能调用出来(在其他程序里依然可以使用,但firefox却不行)!

怀疑是不是和/etc/X11/Xsession.d/95xinput中的设定冲突所致?

export XMODIFIERS=@im=SCIM
export GTK_IM_MODULE="scim"
scim -d

请问,该如何解决?
谢谢!

KDF2003 发表于 2006-9-7 23:43

有问题时先看一下论坛的顶置/精华贴,或者使用用论坛搜索功能,会更快得到答案。

LinuxSir论坛Mandriva板块,
[quote]SCIM 经常与其他程序(如 RealPlayer 10, Mozilla Firefox, Acrobat Reader 7等)冲突,怎么办?
简介
由于Mandrakelinux/Mandriva使用较新的gcc,第三方提供的这些软件包和Mandrakelinux自己的软件包有冲突。以下方法选一:

1.重新编译 SCIM;
2.编辑该文件:vi gtk.immodules
把下面的语句注释掉:
代码:

#"/usr/lib/gtk-2.0/immodules/im-scim.so" #"scim" "SCIM Input Method" "scim" "/usr/share/locale" "*"

3.换用 fcitx。
4.将用户目录下的.i18n文件内的GTK_IM_MODULE=scim条目注释掉,也就是在前面加"#"。[/quote]

页: [1]

Powered by Discuz! Archiver 6.1.0F  © 2001-2007 Comsenz Inc.