中国Linux公社论坛's Archiver

寒水远山 发表于 2006-9-17 13:26

聊天时插入TeX公式的补丁

从Kopete那里修改过来的 :)

需要系统安装LaTeX和ImageMagick

效果见附件

应用补丁:
1. 把附件解压,按照里面的目录结构把图片和脚本解压到eva源码目录
2. 应用补丁diff.patch
3. 可能还需要make -f Makefile.cvs
4. 重新编译安装

yunfan 发表于 2006-9-17 14:20

呵呵,不错,对经常用LaTex朋友很方便 :lol:
不过,我基本不会用LaTex :mrgreen:

寒水远山 发表于 2006-9-17 14:52

呵呵……因为我经常在QQ里面发公式,终于受不了一直生成再截图,于是写了一个……

yunfan 发表于 2006-9-17 15:10

LaTeX和ImageMagick,如果不是这两个额外依赖,我就加你的patch到cvs里了。。

还有什么好的想法,早点弄出来啊,增加eva的易用性 :mrgreen:

三翻领 发表于 2006-9-17 15:27

增加eva涂鸦功能,跟msn里的那支笔一样的功能

寒水远山 发表于 2006-9-17 15:31

这两个依赖是运行以后插入公式时候才检测的,如果不满足的话会提示,并且只是这个功能不能用 :P

eps转jpg可能有别的替代品(不过既然Kopete用ImageMagick,我就直接复制过来了,呵呵,我是标准的懒人),LaTeX的依赖如果要自己写的话,那是宏伟的工程阿  :P

yunfan 发表于 2006-9-17 16:16

我知道你的意思,我的意思就是如果有个按钮,点了提示不能用,会让人非常沮丧的 mrgreen:

寒水远山 发表于 2006-9-17 17:00

[quote:181f87f4c0="yunfan"]我知道你的意思,我的意思就是如果有个按钮,点了提示不能用,会让人非常沮丧的 mrgreen:[/quote]
:oops:

yunfan 发表于 2006-9-17 17:08

linux没个安装标准,大家系统里的东西都不一样,这个问题那是灰常D讨厌, :lol:

mandrakechina 发表于 2006-9-23 14:35

如果不能用,就干脆不要显示,这样就行了。

quhw 发表于 2006-9-25 05:25

imagemagick这个东西应该都有的,latex也很普遍。其实很简单,eva运行的时候检查一下有没有latex和convert就行了,有的话就开放这个功能,没有的话,要不disable这个按钮,要不能不能干脆就不显示按钮?

yacc_deno 发表于 2006-10-4 11:51

make -f Makefile.cvs
产生如下错误
*** YOU'RE USING autoconf (GNU Autoconf) 2.60a.
*** KDE requires autoconf 2.52, 2.53 or 2.54

没有理会,直接编译
./configure --prefix=`kde-config --prefix`
make
make install

安装后的EVA,只要一打开收发信息窗口就崩溃

EVA为30th, September, 2006 yunfan 的CVS

yunfan 发表于 2006-10-4 14:03

能不能把崩溃报告帖来看看?
30号的cvs应该很稳定才对。。。。

寒水远山 发表于 2006-10-4 21:54

[quote:b9f3ea1f0f="yacc_deno"]make -f Makefile.cvs
产生如下错误
*** YOU'RE USING autoconf (GNU Autoconf) 2.60a.
*** KDE requires autoconf 2.52, 2.53 or 2.54

没有理会,直接编译
./configure --prefix=`kde-config --prefix`
make
make install

安装后的EVA,只要一打开收发信息窗口就崩溃

EVA为30th, September, 2006 yunfan 的CVS[/quote]
如果没有make -f Makefile.cvs 的话,一些新的图片文件不会被复制,所以也许会导致崩溃

如果可以的话,也可以手动复制src/image/theme/formula.png和src/latexconvert.sh到安装目录相应文件夹下面 :)

mandrakechina 发表于 2006-10-4 22:51

人家说得很清楚,KDE需要2.5.x,直到KDE 3.5.5才能支持autoconf 2.6。所以你的版本不对。

先把auto*的版本号搞清楚,再玩编译软件吧。

种草得草 发表于 2006-10-5 09:49

可以把补丁打上.
./configure --enable-latex
的时候编译这个公式的补丁,没有enable的时候不编译啊.

yacc_deno 发表于 2006-10-7 12:23

谢谢诸位关注:

问题已解决

Debian(testing)中的KDE现在为3.5.4,autoconf确到了2.6
为了这种小事,升级KDE到3.5.5,或安装一个autoconf2.5.x,就不必了

按照 "寒水远山"兄的指点
复制formula.png到/usr/share/apps/eva/image/theme/下,latexconvert.sh 到/usr/share/apps/eva/下就行了

kliz 发表于 2006-10-14 15:32

附件名应该改成patch.tar.bz2.gz吧
:oops:

寒水远山 发表于 2006-10-15 11:15

[quote:486ead278e="kliz"]附件名应该改成patch.tar.bz2.gz吧
:oops:[/quote]
附件是bzip2压缩的啊? 8O

kliz 发表于 2006-10-16 00:32

难道是上传时自动压缩成gzip了?
8O

mymagic 发表于 2006-10-24 22:33

加个涂鸦功能是不错

页: [1]

Powered by Discuz! Archiver 6.1.0F  © 2001-2007 Comsenz Inc.