中国Linux公社论坛's Archiver

sinclair 发表于 2007-5-4 17:08

编译eva出错?请大家帮帮忙.......

checking for Qt... configure: error: Qt (>= Qt 3.0) (headers and libraries) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
tahoe@Gentoo ~/eva $ ls /usr/lib/qt4
libQtAssistantClient.prl          libQtGui.so.4.3        libQtSql.so.4.3.0
libQtAssistantClient.so           libQtGui.so.4.3.0      libQtSvg.la
libQtAssistantClient.so.4         libQtNetwork.la        libQtSvg.prl
libQtAssistantClient.so.4.3       libQtNetwork.prl       libQtSvg.so
libQtAssistantClient.so.4.3.0     libQtNetwork.so        libQtSvg.so.4
libQtCore.la                      libQtNetwork.so.4      libQtSvg.so.4.3
libQtCore.prl                     libQtNetwork.so.4.3    libQtSvg.so.4.3.0
libQtCore.so                      libQtNetwork.so.4.3.0  libQtTest.la
libQtCore.so.4                    libQtOpenGL.la         libQtTest.prl
libQtCore.so.4.3                  libQtOpenGL.prl        libQtTest.so
libQtCore.so.4.3.0                libQtOpenGL.so         libQtTest.so.4
libQtDesigner.prl                 libQtOpenGL.so.4       libQtTest.so.4.3
libQtDesigner.so                  libQtOpenGL.so.4.3     libQtTest.so.4.3.0
libQtDesigner.so.4                libQtOpenGL.so.4.3.0   libQtUiTools.a
libQtDesigner.so.4.3              libQtScript.la         libQtUiTools.prl
libQtDesigner.so.4.3.0            libQtScript.prl        libQtXml.la
libQtDesignerComponents.prl       libQtScript.so         libQtXml.prl
libQtDesignerComponents.so        libQtScript.so.4       libQtXml.so
libQtDesignerComponents.so.4      libQtScript.so.4.3     libQtXml.so.4
libQtDesignerComponents.so.4.3    libQtScript.so.4.3.0   libQtXml.so.4.3
libQtDesignerComponents.so.4.3.0  libQtSql.la            libQtXml.so.4.3.0
libQtGui.la                       libQtSql.prl           pkgconfig
libQtGui.prl                      libQtSql.so            plugins
libQtGui.so                       libQtSql.so.4
libQtGui.so.4                     libQtSql.so.4.3
tahoe@Gentoo ~/eva $ cat /etc/ld.so.conf
# ld.so.conf autogenerated by env-update; make all changes to
# contents of /etc/env.d directory
/usr/local/lib
//usr//lib/opengl/xorg-x11/lib
/usr/i686-pc-linux-gnu/lib

/usr/lib/gcc/i686-pc-linux-gnu/4.1.1
/usr/lib/nspr
/usr/lib/nss
/usr/lib/qt4
/usr/kde/3.5/lib
/usr/qt/3/lib
/usr/lib/libstdc++-v3/
tahoe@Gentoo ~/eva $

mandrakechina 发表于 2007-5-4 18:38

你没有安装qt3的devel包吧。

另外,qt4和qt3没什么关系。

KDE 发表于 2007-5-9 03:06

[quote:196c8f0236="mandrakechina"]你没有安装qt3的devel包吧。

另外,qt4和qt3没什么关系。[/quote]
你没看见他用的是 Gentoo 么?哪有什么 devel 包?

楼主系统里只有 QT 4,没有 QT 3,当然编译通不过了。

sinclair 发表于 2007-5-20 00:05

首先谢谢2位回复
问题已解决很久了。其实我最早是用emerge 安装了qt-3.3.8的j时候问题也是一样,之后我再升级到qt4的。但是我不明白我用qt3编译eva时还找不到qt?后来急于使用就直接用qt-3.3.8的源码手工编译问题才得到解决。但到现在为止还不明白为什么当时找不到qt3.

页: [1]

Powered by Discuz! Archiver 6.1.0F  © 2001-2007 Comsenz Inc.