中国Linux公社论坛's Archiver

blackfox1977 发表于 2009-1-18 17:17

fcitx不能在进入桌面时自动运行,求助

fcitx版本:
fcitx-3.4.2-bin.tar.bz2
操作系统版本RHEL5,语言我选择的是中文简体(默认)
解压后按照readme的说明直接运行
./fcitx.install
我在root主目录的.bashrc文件中加入了
export XMODIFIERS=@im=fcitx
一行字段,然后在终端中输入fcitx可以运行,可以正常的输入中文,但我希望在登录桌面时fcitx
能够自动运行,我查找了相关资料并作了如下改动:
在/etc/X11/xinit/xinput.d/目录中创建文件zh_CN,内容如下;
XIM=fcitx
XIM_PROGRAM=fcitx
GTK_IM_MODULE=fcitx
gnome-im-settings-daemon >/dev/null

并且按照作者的提醒在.bashrc文件中又加入
export LC_CTYPE="zh_CN"
字段,但是整个关机重启后仍然不能实现fcitx进入桌面后自动运行。
在咱们的论坛也找了若干帖子,都没用,所以求助了。

hades 发表于 2009-1-19 20:16

[url]http://www.linuxsir.org/bbs/thread340027.html[/url]

看看能不能帮你的忙。

页: [1]

Powered by Discuz! Archiver 6.1.0F  © 2001-2007 Comsenz Inc.