中国Linux公社论坛's Archiver

一下打死七个 发表于 2010-8-19 20:58

有人没,debian 5安装grub到硬盘失败

在服务器上安装debian5
以前也安装过,出现同样的情况
这次用最新的稳定版5.05
全部安装完成后
最后出错,无法将grub安装至硬盘
选lilo也同样
这样的话,系统无法启动

而以前4的时候,从未有过这样的情况
求助...:(

一下打死七个 发表于 2010-8-19 21:02

刚搜索了下
是不是grub必须安装在主分区上?
我的分区是这样的
/ (主分区,引导)
/boot
/...

我再去试试

jiangtao9999 发表于 2010-8-19 22:36

通常情况下……
RPWT ……
:?

一下打死七个 发表于 2010-8-19 22:37

把/boot作主分区还是不行
看来只能明天安装debian4了

jiangtao9999 发表于 2010-8-19 23:21

不可能吧……
怎么不能启动?是不是机器太老或者太新?

一下打死七个 发表于 2010-8-19 23:37

用了五年左右的服务器
debian4安装一切正常
而5却无法安装grub
郁闷了,年初就试过
也是同样的情况

[[i] 本帖最后由 一下打死七个 于 2010-8-19 23:39 编辑 [/i]]

jiangtao9999 发表于 2010-8-20 00:25

手动安装 grub 呢?不行就先装好 debian5 ,之后再用 debian 4 的 grub 呢?

一下打死七个 发表于 2010-8-20 09:41

用 debian 4 的 grub?
咋解?
我现在安装完5了
但无法启动
LILO和grub都无法安装

jiangtao9999 发表于 2010-8-20 10:35

下载debian的grub。服务器用livecd启动chroot过去降级安装下载的grub deb包。之后手动进入grub命令行重新装到mbr

jiangtao9999 发表于 2010-8-20 10:36

你先手动安装grub一下,看看是不是安装程序的问题。

一下打死七个 发表于 2010-8-20 17:09

我还是找出了4的安装盘
安装基本的系统,然后update
系统就直接被升级到了5了
已经可以正常启动了

我的系统本来跑得好好的
昨天想做一下更新,打点补丁
更新的时候也没仔细看
被更新了N多软件名
再看版本号,被强制升级到5了
查看启动项,发现了上十条
原来4的时候是很清爽的
我也不知有用没有,就关掉了不少
结果杯具了...:cry:

多谢涛涛!:mrgreen:

muwanqing 发表于 2010-9-1 19:25

LS也用Linux????悲剧了

杀毒新狂人 发表于 2011-11-9 19:52

这个还没有研究过,无发言权

zz_6_3 发表于 2011-12-9 00:12

俺用Debian6,以前装Debian5也得装挺好的啊。是不是因为LZ下的镜像有问题呢?

从8月份出差就没回过,一直没时间弄Linux。上次同事的电脑出问题,我用我去年装在U盘上的Debian6去启动,结果,连装在U盘上的Debian都启动不了。貌似GRUB2的配置中是用了UUID的。

还有件麻烦事:俺不能在水园发贴啊,真纠结!!!
最后一件事:俺准备聚集几个同学一起,在网上接项目:) 目前刚开始召集到人:mrgreen:

zz_6_3 发表于 2012-3-22 23:26

是不是装上后只能到
Welcome to GRUB!
之后就再也进不了了?

我在移动硬盘上装了两次都是这样的,第一次安装可以启动,后来重装就启动不了了。不知道什么原因。目前想在已经安装的LINUX上用GRUB先进去,再重装GRUB试试

zz_6_3 发表于 2012-3-22 23:32

是不是装上后只能到
Welcome to GRUB!
之后就再也进不了了?

我在移动硬盘上装了两次都是这样的,第一次安装可以启动,后来重装就启动不了了。不知道什么原因。目前想在已经安装的LINUX上用GRUB先进去,再重装GRUB试试

页: [1]

Powered by Discuz! Archiver 6.1.0F  © 2001-2007 Comsenz Inc.