打印

新人求助 skyeye 1.3.1 make lib 报错

新人求助 skyeye 1.3.1 make lib 报错

新人求助 skyeye 1.3.1 make lib 报错
我用vmware 安装了 ubuntu 10 和
然后下载了skyeye-1.3.1
并按照网上的安装方法,安装
./configure -->OK
可是在输入make lib 后 出现了错误
错误如下:c.lo binary.lo tekhex.lo ihex.lo stabs.lo stab-syms.lo merge.lo dwarf2.lo simple.lo `cat ofiles` -L../libiberty/pic -liberty
libtool: link: cannot find the library `' or unhandled argument `File/skyeye/skyeye-1-3-1_rc1/third-party/libiberty/pic'
make[3]: *** [libbfd.la] Error 1
make[3]: Leaving directory `/home/user/MY File/skyeye/skyeye-1-3-1_rc1/third-party/bfd'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/user/MY File/skyeye/skyeye-1-3-1_rc1/third-party/bfd'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/home/user/MY File/skyeye/skyeye-1-3-1_rc1/third-party/bfd'
make: *** [lib] Error 2
user@ubuntu1004desktop:~/MY File/skyeye/skyeye-1-3-1_rc1$ ls
有人知道怎么解决吗?谢谢了

TOP

ubantu好像可以直接安装二进制。

sudo apt-get install skyeye

[ 本帖最后由 cryy 于 2010-8-23 10:15 编辑 ]

TOP

需要添加多种库

ubuntu10安装需要一定的支持库,有一些库文件是需要独立安装的。
sudo apt-get install libgtk2.0-dev pkg-config libatk1.0-dev libpango1.0-dev libfreetype6-dev libglib2.0-dev libx11-dev binutils-dev
具体见前面文章,安装库就可以编译了

TOP