找回密码
 注册
查看: 1536|回复: 4

smb的问题,快要疯掉了

[复制链接]
发表于 2007-1-5 01:46:16 | 显示全部楼层 |阅读模式
linux防火墙也用命令/etc/rc.d/init.d/ipchains stop关闭了
这是我的smb.conf文件:
[global]
workgroup = WORKGROUP
server string = Samba Server
netbios name = ww
hosts allow = 192.168.0. 192.168.1. 127.
security = user
client code page=936
guest account=nobody
security = share
encrypt passwords = yes

[home]
path = /home
public = yes
writable = yes
create mask = 0777

smbpasswd文件中有下面一项:
yangqian:500:904021AAA178696DAAD3B435B51404EE:E8CD0E4A9E89EAB931DC5338FCBEC54A:[U          ]:LCT-459D36FF:yangqian


smbusers文件的内容是:
# Unix_name = SMB_name1 SMB_name2 ...
root = administrator admin
nobody = guest pcguest smbguest

我也在命令行下执行smbpasswd -a yangqian了

在XP系统下  \\192.168.0.105 ,显示home和打印机。可是点击home的时候,说我没有权限访问网络资源,可是点击打印机能进去。
很苦闷!!!
发表于 2007-1-5 09:51:36 | 显示全部楼层
如果是guest用户的话,把/home的访问权限设成775试试。
[code:1]
chmod 775 /home
/etc/init.d/samba restart
[/code:1]
回复 支持 反对

使用道具 举报

发表于 2007-1-5 10:57:07 | 显示全部楼层
添加samba user的话。要求samba用户名也要有存在的系统用户名吧?我说的对么?请指正.
回复 支持 反对

使用道具 举报

发表于 2007-1-10 14:47:28 | 显示全部楼层
去掉 guest account=nobody
[global]
netbios name = hifan server
invalid users = root
security = user
workgroup = WORKGROUP
server string = hifan SMB
socket options = TCP_NODELAY SO_RCVBUF=32768 SO_SUDBUF=32768
deadtime = 1
os level = 30
host msdfs = yes
#dos char set = CP936
#unix chars = gb2312
stat cache size = 64
null passwords = yes
map to guest = Bad Password
encrypt passwords = yes
getwd cache = yes
auto services = global
回复 支持 反对

使用道具 举报

发表于 2007-1-12 15:40:57 | 显示全部楼层
查你passwd中有没有yangqian,还有/home目录yangqian有没有读写的权限
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

GMT+8, 2021-12-6 17:09 , Processed in 0.041937 second(s), 15 queries .

© 2021 Powered by Discuz! X3.4.

快速回复 返回顶部 返回列表