Board logo

标题: 很奇怪的系统时间问题 ?!!!! [打印本页]

作者: liangsong    时间: 2007-5-20 16:26     标题: 很奇怪的系统时间问题 ?!!!!

刚刚在NB上装好了RHEL5,突然发现我的系统时间和实际时间不吻合,仔细一

瞧,发现在正常时间的1秒中内它跑了大概3秒,真让人体验到时间飞逝的感

觉, 请问有那位达人知道是那里出了毛病?该如何操作修正?


谢谢!!!

注:在WINDOWS下面系统时间是正常的!
作者: DRIFT    时间: 2007-5-21 19:27

有这等奇事!如果过3秒跑1秒就好了,用相对论来讲就是时间倒流了
作者: liangsong    时间: 2007-5-22 14:39

呵呵 不管是倒流 还是超前  对于电脑来说做不了事啊
作者: npcomet    时间: 2007-5-22 14:44

http://www.linuxfans.org/nuke/modules.php?name=Forums&file=viewtopic&p=4702665

[quote:09792fc5ba="npcomet"]Linux 在驱动 AMD + ATI 的系统会有一个 bug,使得系统时钟比物理时钟整整快一倍。解决这个问题,可以修改 /boot/grub/menu.lst,在 kernel 命令中加入 noapictimer 参数。


如,有一 kernel 命令如下:

kernel /boot/vmlinuz-2.6.12-10-k7 root=/dev/hda3 ro quiet splash


将这行改为

kernel /boot/vmlinuz-2.6.12-10-k7 root=/dev/hda3 ro noapictimer quiet splash


再重启即可[/quote]
增加一个 noapictimer 参数
作者: liangsong    时间: 2007-5-22 16:15

呵呵 坛主大驾 赶快试试先 !!!!
作者: liangsong    时间: 2007-5-22 17:25

还是不行 没任何改变 ,我去查/VAR/LOG/BOOT.LOG里面是空的

然后在启动的时候我看到了这样的错误

applying intel cpu microcode update :FATAL: module microcode not found
error :module microcode does not exit in /proc/modules                 [FAILED]

注明下 , 我的电脑配置是:
CPU类型 Core 2 Duo T5500(Merom-667) 标称频率 1.66GHz  
主板描述 I945GM  
内存类型 DDRII   1.5G
显卡芯片 Intel GMA950  



安装的是RHEL5


另外我在/var/log/dmesg里发现了好多的 time went backwards ,我发了另外个贴是有关这个的 现摘录如下:
Timer ISR/0: Time went backwards: delta=-10048465 cpu_delta=9951535
shadow=706605145 0: 71640046095
1: 71660000000
Timer ISR/0: Time went backwards: delta=-10044816 cpu_delta=19955184
shadow=71660475 0: 71660046095
1: 71690000000
Timer ISR/0: Time went backwards: delta=-6038496 cpu_delta=13961504
shadow=716604705 0: 71670046095
1: 71700000000
Timer ISR/1: Time went backwards: delta=-580042799 cpu_delta=460003296
shadow=716600 0: 73240046095
1: 72200000000
Timer ISR/0: Time went backwards: delta=-10039377 cpu_delta=9960623
shadow=732371225 0: 73240046095
1: 73260000000
Timer ISR/0: Time went backwards: delta=-10040262 cpu_delta=29959738
shadow=73237125 0: 73240046095
1: 73280000000

我在GOOGLE上搜索下,有篇文章是关于这个的,但是没看到解决办法,链接:
http://bugzilla.xensource.com/bugzilla/show_bug.cgi?id=195

达人们帮帮手,折腾快一个礼拜了 !!!!
作者: npcomet    时间: 2007-5-22 20:10

如果是虚拟机看下这里

http://linux.chinaunix.net/bbs/viewthread.php?tid=819606
作者: liangsong    时间: 2007-5-23 10:59

不是VM,是从硬盘上的光盘映象安装在笔记本上的 ,系统安装后可以在X WINDOW使用,但是在SHELL下就无法使用,原因是不断的有TIME WENT BACKWARDS跳出来,很奇怪它不写到日志里,怎么直接就在SHELL里显示,系统装好没做任何修改。会不会是光盘映象有问题,我下载了镜像没做MD5检查。但好像也不是我一个人的问题,在我贴的那个网址上面有很多人遇到过这个问题。
作者: trinitite    时间: 2011-4-13 00:15

我的是VM,学习了,刚开始下了一跳




欢迎光临 中国Linux公社论坛 (http://forum.linuxfans.org/) Powered by Discuz! 6.1.0F