打印

lighttpd 1.4.x 爆高危漏洞

lighttpd 1.4.x 爆高危漏洞

lighttpd(发音为lighty)是一套开放源代码的网页服务器,以BSD许可证放出.相较于其他的网页服务器,lighttpd仅需少量的 内存及CPU资源即可达到同样的效能.今天lighttpd 张贴公告修复了一个已知的严重bug.可能会给 DoS/OOM 攻击以可乘之机.Li Ming (貌似是国人) reported a serious bug in lighttpd:
If you send the request data very slow (e.g. sleep 0.01 after each byte), lighttpd will easily use all available memory and die (especially for parallel requests), allowing a DoS within minutes.
See:

The bug is tracked as CVE-2010-0295.

As far as we know all versions are affected.

该漏洞影响1.4.26以下 和  r2710 之前的所有lighttpd版本.如果你正在使用的话,

可以选择patch 修复.

补丁下载:

http://download.lighttpd.net/lighttpd/security/lighttpd-1.4.x_fix_slow_request_dos.patch (适用于1.4.x)
http://download.lighttpd.net/lighttpd/security/lighttpd-1.5_fix_slow_request_dos.patch (适用于1.5.x)

或者 check out 最新版本.

TOP

1.4.26 版本还没有公布吧。
http://download.lighttpd.net/lig ... .26rc1-r2710.tar.gz

[ 本帖最后由 haulm 于 2010-2-4 10:33 编辑 ]
http://haulm.clanmark.com
自古多情空余恨,几人独潇洒。
问君相伴何所思,唯叹红叶飞。
凭栏窗外一皓月,冷风抚面,寒星如冰。
回想前事独伤感,难分难离,倒是山峦草芥,依旧青。

TOP