打印

Android 2.3.4以下的系统不自带配件功能吗?

Android 2.3.4以下的系统不自带配件功能吗?

Android开发的那个东西交给别人去折腾去了,但因为我摸过一点点那个项目,所以,那个新接手的人遇到问题总是问我。其实这个问题我也想知道,但网上貌似没找到好的答案,在这里问一下,看看有没有哪位知道。
问题是这样的:
我用SM-G3508(Android 4.1.2的系统)、ADT最新开发环境、Arduino的开发板做配件开发时完全可以。
现在,其它东西都不变(代码也是SM-G3508一样的),只把手机换成其它手机,再把Android程序的targetSDK设置成所换手机对应的版本,但这样就不行。apk可以安装上去,但用手机连Arduino开发板之后,Arduino开发板的调试信息总显示版本不匹配(具体什么信息不记得了,明天再补上来)。

目前试过的其它手机有:
一个刷了小米系统的华为手机,系统是Android 4.4的
谷歌手机,系统是Android 4.2还是4.1的倒是不记得了,反正超过了2.3.4(明天补上具体版本)

按查的资料来说,只要是Android 2.3.4和这个版本之后的Android系统都支持配件模式,但为什么SM-G3508可以用,而其它两个比SM-G3508系统版本还高的手机不行呢?


哪位大大指点一下,谢谢!

TOP

回复 3# zy_sunshine 的帖子

通过USB线连

TOP

引用:
原帖由 jiangtao9999 于 2014-9-26 16:02 发表
不会是接口协议变了导致不能识别吧?
或者没开这个功能?
不清楚

TOP

问题解决,原因是开发环境中的调用的驱动版本过低(应该是Arduino那一端,问题不是我解决的,所以不清楚)

TOP