打印

BitStorm 0.2p Lite released

没有图标吗?

另外,按照一般软件的写法,如果一个软件只以一种授权协议释放的话,COPYING文件应该原文照搬该授权协议的内容。按照BitStorm的情况,COPYING文件应该是GPL 2的内容,而不是现在的一句话。
真男人张湘祥

TOP

谢谢 mandrakechina,我会把GPL 2加到COPYING里

图标没有

TOP

我以前曾经在kde-look上找到一组图标,是那种地球旁边有闪电的。似乎和Bitstorm有点像,而且还是多种颜色的。
真男人张湘祥

TOP

ml 2.0rc1
引用:
terminate called after throwing an instance of 'std::logic_error'
  what():  basic_string::_S_construct NULL not valid
已放弃
爱生活,

TOP

to dalin:
这是个bug,暂时的解决办法有两个:
1。用命令行参数打开torrent文件,例如bitstormlite /home/gxc/aaa.torrent
利用文件管理器就可以很方便的双击torrent文件打开程序
2。确保torrent文件路径中没有中文,可以将torrent文件或路径改为英文名

TOP

[quote:86128e0699="dalin"]ml 2.0rc1
引用:
terminate called after throwing an instance of 'std::logic_error'
  what():  basic_string::_S_construct NULL not valid
已放弃
[/quote]

补丁如下:
[code:1]
--- BitStormLite-0.2b/src/utils.h.orig        2006-01-16 20:51:12.000000000 +0000
+++ BitStormLite-0.2b/src/utils.h        2006-01-16 20:45:22.000000000 +0000
@@ -380,7 +380,7 @@
        gsize bytes_written;
       
        gchar* ret = g_filename_from_utf8(input_text, -1, &bytes_read, &bytes_written, NULL);
-        std::string result = ret;
+        std::string result = ret ? ret : input_text;
        g_free(ret);
       
        return result;
[/code:1]
業精于勤,荒于嬉

TOP

to KanKer老乡:
本来以为gtk_file_chooser_get_filename返回的是UTF-8编码的字符串,结果不是
上面那个patch有点治标不治本

TOP

霍霍,是啊。不过能用就行了  
業精于勤,荒于嬉

TOP

还是慢。我在Windows下用Bitcomet有时可以达到600多K。用Ubutn下的bittorent也可以有150KB的稳定速度。可是用这个在Magiclinux下只有不到100KB的速度。声明,种子是一样的,而且用户极多。
一只linux菜鸟

TOP

感觉下载不太稳定,比如新加了一批客户下载,速度会一直降下很多。
因此我感觉对热门的种子下载的速度不行,对其他有稳定供种的速度还行.
是不是算法上有点问题?

TOP

Re: BitStorm 0.2b Lite release

checking for GTK... configure: error: Package requirements (gtk+-2.0 >= 2.6.0) were not met.
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively you may set the GTK_CFLAGS and GTK_LIBS environment variables
to avoid the need to call pkg-config.  See the pkg-config man page for
more details.
编译着出现些错误在dapper上。

TOP

搞定安装上libgtk2.0-dev就行了。

TOP

我也有同样的问题,但我检查过了,我系统上有gtk啊,而且版本也达到要求了。为什么还有这个错误呢?

我是debian 2.4内核
断翅天使

TOP

粗心看错了,发现我确实没有装libgtk。。
断翅天使

TOP

[quote:a6f6dd6e5e="peaceman"]checking for GTK... Requested 'gtk+-2.0 >= 2.6.0' but version of GTK+ is 2.4.0
configure: error: Package requirements (gtk+-2.0 >= 2.6.0) were not met.
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively you may set the GTK_CFLAGS and GTK_LIBS environment variables
to avoid the need to call pkg-config.  See the pkg-config man page for
more details.

我得是红旗4.1[/quote]
一般红旗装个软件很困难。
Mike

TOP