打印

如何在Rocket 2720 RAID卡上安装Elastix?我快崩溃了

如何在Rocket 2720 RAID卡上安装Elastix?我快崩溃了

近日接到一个任务,在一个白牌服务器上安装Elastix发布版(基于CENTOS的一个语音服务器专用发布版)。由于这个RAID卡的驱动程序不被安装程序支持,所以在安装系统时找不到硬盘。
我尝试了以下解决方案,全部出现问题。

方案一:下载Highpoint-tech官方的rocket 2720驱动,由于官网仅提供了针对于CENTOS 5.X的驱动,所以反复尝试都不能在Elastix安装程序中使用linux dd加载成功。虽然在尝试使用CENTOS 5.2时成功加载了驱动,但却卡死在系统删除硬盘数据并分区的位置。

方案二:在内核源文件中打驱动补丁,然后编译安装光盘中的内核源文件
驱动目录下:
#make patchkernel KERNELDIR=<kernel-source-dir> KERNEL_VER=2.6
系统提示目标目录不是完整的源码树
甚至我不改任何内核选项,直接make bzImage都不行。
查了些资料说,红帽哥的多数版本内核源码文件只能make menuconfig和make modules(太不讲究了),并非真正的源码包。

方案三:下载了标准内核源文件,编译成功通过了。但是在使用新内核启动现有的虚拟机中的Elastix时,系统提示dahdi错误,加载不了。而这个dahdi在我百度后发现就是PBX交换机管理了核心文件不带不行。又百度了一下说这些文件依赖于特定的内核版本。我擦!我怎么才能搞定这个问题啊?我快崩溃了.

说得有点乱,总结一下:
我就是想在这个rocket 2720卡上安装这个Elastix发布版,无论是什么办法都行,各位高手帮忙。


祝各位坛友新年快乐,多发横财!

TOP

顶顶更健康,顺便强烈鄙视不公布内核源代码的发行商。

TOP

不被安装程序支持,能被系统内核支持么?如果能被系统内核支持,可以用其它的,比如centos的安装程序来安装。

TOP

这个系统针对于一些专用的硬件开发了不少东西,我没法改用CENTOS的内核,而且CENTOS也不认啊。

TOP

引用:
原帖由 冷雨夜 于 2012-1-28 04:11 发表
这个系统针对于一些专用的硬件开发了不少东西,我没法改用CENTOS的内核,而且CENTOS也不认啊。
不是改用centos的内核,而是用centos的安装程序。可以进入centos的livecd的话,可以手工安装rpm包,或者使用centos的安装制作程序重新制做安装盘(magic的安装程序可能制作比较容易,不过不知道能不能支持你的系统)

TOP