找回密码
 注册
楼主: gxcooo

BitStorm 0.2p Lite released

[复制链接]
发表于 2005-12-21 13:09:36 | 显示全部楼层
这个是什么错误?
configure: error: the curl-config script installed by libcurl could not be found                    
.  libcurl is required.
回复 支持 反对

使用道具 举报

 楼主| 发表于 2005-12-21 14:16:30 | 显示全部楼层
to sunperz:
请安装libcurl-dev
回复 支持 反对

使用道具 举报

 楼主| 发表于 2005-12-21 14:18:51 | 显示全部楼层
to sunperz:
请安装libcurl-dev
回复 支持 反对

使用道具 举报

发表于 2005-12-25 13:42:48 | 显示全部楼层

我在FC4下也搞不定,同样的错误

[quote:734dc3fba1="peaceman"]checking for GTK... Requested 'gtk+-2.0 >= 2.6.0' but version of GTK+ is 2.4.0
configure: error: Package requirements (gtk+-2.0 >= 2.6.0) were not met.
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively you may set the GTK_CFLAGS and GTK_LIBS environment variables
to avoid the need to call pkg-config.  See the pkg-config man page for
more details.

我得是红旗4.1[/quote]

看到楼上说需要安装libgtk2.0的包,在网上找了半天也没有弄到,哪位大哥帮帮忙啊。
回复 支持 反对

使用道具 举报

发表于 2006-1-19 00:18:08 | 显示全部楼层
比较完整的一个 deb 包
设置了 mime , desktop file。
不过 Duild-Depends 可能还不够完整,慢慢来吧。

http://linuxfire.dhis.org/~optical/Debian/bitstormlite/
回复 支持 反对

使用道具 举报

 楼主| 发表于 2006-1-19 10:01:17 | 显示全部楼层
谢谢dlz_cn
回复 支持 反对

使用道具 举报

发表于 2006-1-19 10:47:17 | 显示全部楼层
$ sudo dpkg -i bitstormlite_2.0b-0.0_i386.deb
dpkg-deb: “bitstormlite_2.0b-0.0_i386.deb”并非 debian 格式的包文件
dpkg:处理 bitstormlite_2.0b-0.0_i386.deb (--install)时出错:
子进程·dpkg-deb --control·返回了错误号·2
在处理时有错误发生:
bitstormlite_2.0b-0.0_i386.deb

  
回复 支持 反对

使用道具 举报

发表于 2006-1-19 11:02:45 | 显示全部楼层
我刚才在更新

重新下载吧。
回复 支持 反对

使用道具 举报

发表于 2006-1-21 06:41:13 | 显示全部楼层
[code:1]$ sudo dpkg -i bitstormlite_0.2b-0.0_i386.deb
(正在读取数据库 ... 系统当前总共安装有 60864 个文件和目录。)
正预备替换 bitstormlite 0.2b-0.0 (使用 bitstormlite_0.2b-0.0_i386.deb) ...
正在解压缩将用于更替的包文件 bitstormlite ...
dpkg:依赖关系问题使得 bitstormlite 的配置工作不能继续:
bitstormlite 依赖于 libcairo2 (>= 1.0.2-2);然而:
  系统里的 libcairo2 的版本是 1.0.2-0ubuntu1.
bitstormlite 依赖于 libcurl3 (>= 7.15.0-1);然而:
  系统里的 libcurl3 的版本是 7.14.0-2ubuntu1.
bitstormlite 依赖于 libgcc1 (>= 1:4.0.2);然而:
  系统里的 libgcc1 的版本是 1:4.0.1-4ubuntu9.
bitstormlite 依赖于 libglib2.0-0 (>= 2.8.5);然而:
  系统里的 libglib2.0-0 的版本是 2.8.3-0ubuntu1.
bitstormlite 依赖于 libidn11 (>= 0.5.18);然而:
  系统里的 libidn11 的版本是 0.5.13-1.0.
bitstormlite 依赖于 libkrb53 (>= 1.4.2);然而:
  系统里的 libkrb53 的版本是 1.3.6-4.
bitstormlite 依赖于 libpango1.0-0 (>= 1.10.2);然而:
  系统里的 libpango1.0-0 的版本是 1.10.1-0ubuntu1.
bitstormlite 依赖于 libssl0.9.8 (>= 0.9.8a-1);然而:
  软件包 libssl0.9.8还没有被安装。
bitstormlite 依赖于 libstdc++6 (>= 4.0.2-4);然而:
  系统里的 libstdc++6 的版本是 4.0.1-4ubuntu9.
bitstormlite 依赖于 libxrender1 (>= 1:0.9.0.2);然而:
  系统里的 libxrender1 的版本是 1:0.9.0-1.
dpkg:处理 bitstormlite (--install)时出错:
依赖关系问题 - 仍未被配置
在处理时有错误发生:
bitstormlite[/code:1]


现在库里面好像都没有这么高的版本 :-(
这要是一个一个包的找还不累死了!
你的testing包是从哪里下载的??
回复 支持 反对

使用道具 举报

发表于 2006-1-21 14:42:29 | 显示全部楼层
你搞错版本的。
我 deb 里面写 unstable 当然就是给 debian sid 用的。

ubuntu 就得你自己重新编译了。

这些和 testing (debian etch) 没有什么关系。
回复 支持 反对

使用道具 举报

发表于 2006-1-21 15:55:57 | 显示全部楼层
[quote:f1fd97f148="dlz_cn"]你搞错版本的。
我 deb 里面写 unstable 当然就是给 debian sid 用的。

ubuntu 就得你自己重新编译了。

这些和 testing (debian etch) 没有什么关系。[/quote]

            
回复 支持 反对

使用道具 举报

发表于 2006-1-21 22:09:23 | 显示全部楼层
还好,终于编译成功了!

奇怪前几次为什么编译总是通不过??莫非是RPWT?? :-(
回复 支持 反对

使用道具 举报

发表于 2006-1-21 22:11:39 | 显示全部楼层
PS TO:gxcooo

俺很喜欢你的这个软件!
回复 支持 反对

使用道具 举报

发表于 2006-1-22 17:21:07 | 显示全部楼层
救命!sourceforge上不了了!
回复 支持 反对

使用道具 举报

发表于 2006-1-28 20:10:34 | 显示全部楼层
to gxcooo

春节快乐!
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

GMT+8, 2022-8-19 15:49 , Processed in 0.072424 second(s), 13 queries .

© 2021 Powered by Discuz! X3.4.

快速回复 返回顶部 返回列表