找回密码
 注册
查看: 3644|回复: 6

gentoo 升级 world 提示 slot conflict 问题

[复制链接]
发表于 2013-7-31 14:36:31 | 显示全部楼层 |阅读模式
各位兄台,今天升级 world 提示:
  1. !!! Multiple package instances within a single package slot have been pulled
  2. !!! into the dependency graph, resulting in a slot conflict:

  3. dev-libs/libgcrypt:0

  4.   (dev-libs/libgcrypt-1.5.3::gentoo, ebuild scheduled for merge) pulled in by
  5.     (no parents that aren't satisfied by other packages in this slot)

  6.   (dev-libs/libgcrypt-1.5.0-r2::gentoo, installed) pulled in by
  7.     >=dev-libs/libgcrypt-1.1.42:0/0= required by (dev-libs/libxslt-1.1.28-r1::gentoo, installed)

  8. dev-libs/icu:0

  9.   (dev-libs/icu-51.1::gentoo, ebuild scheduled for merge) pulled in by
  10.     dev-libs/icu:0/51.1 required by (app-office/libreoffice-bin-4.0.4.2::gentoo, ebuild scheduled for merge)

  11.   (dev-libs/icu-49.1.2::gentoo, installed) pulled in by
  12.     dev-libs/icu:0/0= required by (sys-apps/gptfdisk-0.8.6::gentoo, installed)

  13. sys-libs/zlib:0

  14.   (sys-libs/zlib-1.2.7::gentoo, installed) pulled in by
  15.     (no parents that aren't satisfied by other packages in this slot)

  16.   (sys-libs/zlib-1.2.7::gentoo, ebuild scheduled for merge) pulled in by
  17.     >=sys-libs/zlib-1.2.5.1-r2:0[minizip] required by (dev-db/virtuoso-server-6.1.6::gentoo, ebuild scheduled for merge)

  18. It may be possible to solve this problem by using package.mask to
  19. prevent one of those packages from being selected. However, it is also
  20. possible that conflicting dependencies exist such that they are
  21. impossible to satisfy simultaneously.  If such a conflict exists in
  22. the dependencies of two different packages, then those packages can
  23. not be installed simultaneously.
复制代码
这个解释是什么意思,不太懂:

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

最新的 dev-libs/libgcrypt-1.5.3 满足 >=dev-libs/libgcrypt-1.1.42 依赖
最新的 sys-libs/zlib-1.2.7 也满足 >=sys-libs/zlib-1.2.5.1-r2 依赖

为什么不让装。。。


---
发表于 2013-7-31 15:36:51 | 显示全部楼层
你得结合前面的提示看
你贴的这些只是一部分,表明这些软件包都被谁依赖了。
回复 支持 反对

使用道具 举报

 楼主| 发表于 2013-7-31 16:26:58 | 显示全部楼层
---

mask 掉这几个新的软件包,重新更新的所有输出贴到这里了:http://ix.io/6XK

=dev-libs/libgcrypt-1.5.2-r1
=dev-libs/icu-51.1
=app-office/libreoffice-bin-4.0.4.2
=dev-db/virtuoso-server-6.1.6

这段显示,应该是下面这些软件包导致的依赖问题吧:

  1. The following mask changes are necessary to proceed:
  2. (see "package.unmask" in the portage(5) man page for more details)
  3. # required by dev-libs/soprano-2.9.2[virtuoso]
  4. # required by kde-base/nepomuk-widgets-4.10.5
  5. # required by kde-base/kdelibs-4.10.5-r1[semantic-desktop]
  6. # required by kde-base/phonon-kde-4.10.5
  7. # required by kde-base/kdebase-startkde-4.10.5
  8. # required by @selected
  9. # required by @world (argument)
  10. # /etc/portage/package.mask:
  11. =dev-db/virtuoso-server-6.1.6
复制代码
现在的系统没有安装:dev-db/virtuoso-server 和 dev-libs/soprano-2.9.2[virtuoso]

如果 mask 掉 =sys-libs/zlib-1.2.7 会出现这个提示,应该是 dev-db/virtuoso-server 依赖旧版本的 sys-libs/zlib-1.2.5.1-r2 但是现在系统安装的已经是新版的 sys-libs/zlib-1.2.7

  1. sys-libs/zlib:0

  2.   (sys-libs/zlib-1.2.5.1-r2::gentoo, ebuild scheduled for merge) pulled in by
  3.     >=sys-libs/zlib-1.2.5.1-r2:0[minizip] required by (dev-db/virtuoso-server-6.1.6::gentoo, ebuild scheduled for merge)

  4.   (sys-libs/zlib-1.2.7::gentoo, installed) pulled in by
  5.     >=sys-libs/zlib-1.2.6 required by (sys-apps/kmod-13-r1::gentoo, ebuild scheduled for merge)
复制代码
---
回复 支持 反对

使用道具 举报

 楼主| 发表于 2013-7-31 16:35:31 | 显示全部楼层
---
  1. · sudo emerge -avj sys-libs/zlib      

  2. [ebuild   R    ] sys-libs/zlib-1.2.7  USE="-minizip -static-libs" 548 kB
复制代码
现在的 sys-libs/zlib 没有启用 minizip USE 我添加之后就 OK 了

---
回复 支持 反对

使用道具 举报

发表于 2013-7-31 16:56:05 | 显示全部楼层

叫你不看全了
回复 支持 反对

使用道具 举报

 楼主| 发表于 2013-7-31 17:16:33 | 显示全部楼层
可能我把焦点全放到错误提示了,添加了

  1. # required by dev-db/virtuoso-server-6.1.6
  2. # required by dev-libs/soprano-2.9.2[virtuoso]
  3. # required by kde-base/nepomuk-widgets-4.10.5
  4. # required by kde-base/kdelibs-4.10.5-r1[semantic-desktop]
  5. # required by kde-base/phonon-kde-4.10.5
  6. # required by kde-base/kdebase-startkde-4.10.5
  7. # required by @selected
  8. # required by @world (argument)
  9. =sys-libs/zlib-1.2.7 minizip
复制代码
把其他的两个 mask 去掉,都 OK 了,还是有些奇怪,为什么之前会有冲突
之后就没有冲突了?

  1. [ebuild  rR    ] dev-libs/libxslt-1.1.28-r1  USE="crypt -debug -python -static-libs" PYTHON_TARGETS="python2_7 -python2_5 -python2_6" 0 kB
  2. [ebuild  r  U  ] dev-libs/icu-51.1:0/51.1 [49.1.2:0/0] USE="-debug -doc -examples -static-libs" 21,304 kB
  3. [ebuild  r  U  ] dev-libs/libgcrypt-1.5.3:0/11 [1.5.0-r2:0/0] USE="-static-libs" 1,474 kB
  4. [ebuild  rR    ] sys-apps/gptfdisk-0.8.6  USE="icu ncurses -static" 0 kB
复制代码
回复 支持 反对

使用道具 举报

发表于 2013-7-31 18:37:12 | 显示全部楼层
估计是因为有软件依赖  zlib 的 minizip 的 USE 。有些软件不需要,但升级又需要某些软件一起升级,导致依赖 minizip 的软件和不需要 minizip 的软件和 zlib 互相之间和依赖依赖minizip的软件的软件产生了一个依赖冲突。
这东西必须看全了,那些依赖的提示,只是说当前有问题的软件包被谁依赖。只是方便你进行取舍的东西。对于实际问题的所在,不在这些提示上。
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 注册

本版积分规则

GMT+8, 2021-12-1 02:19 , Processed in 0.045732 second(s), 15 queries .

© 2021 Powered by Discuz! X3.4.

快速回复 返回顶部 返回列表